Possible Intermittent Analytics Impact

Incident Report for Dragon Systems US and Canada

Resolved

This incident has been resolved.
Posted May 19, 2026 - 09:01 EDT

Identified

Microsoft is currently aware of an intermittent analytics-related impact stemming from a Microsoft Fabric / Power BI issue. Our engineering teams are actively investigating.

Current symptoms include:
-Service Unavailable errors
-Delays when loading analytics

At this time, there is no confirmed workaround. However, some users have reported intermittent success by restarting the application and retrying the operation.
We will continue to provide updates as more information becomes available. Thank you for your patience while we work to resolve this issue.

Azure Status Link: https://azure.status.microsoft/en-us/status
Posted May 18, 2026 - 14:09 EDT
This incident affected: Nuance Healthcare Analytics (Nuance Healthcare Analytics - United States, Nuance Healthcare Analytics - Canada).