test incident

Incident Report for Dragon Systems US and Canada

Resolved

resolved status test
Posted Feb 19, 2026 - 09:02 EST

Monitoring

Monitor status check
Posted Feb 19, 2026 - 08:17 EST

Identified

test identified status
Posted Feb 19, 2026 - 08:07 EST

Investigating

testing status page activities, no product status change or impact
Posted Feb 19, 2026 - 08:01 EST
This incident affected: Nuance Healthcare Analytics (Nuance Healthcare Analytics - United States).