Possible NMS/NMC Impact

Incident Report for Dragon Systems US and Canada

Resolved

Upon investigation a regional issue was identified and has been immediately remediated.
Posted Aug 01, 2026 - 19:50 EDT

Investigating

We are currently investigating an issue where admins may not be able to add new users to NMC. We will provide an update shortly
Posted Aug 01, 2026 - 18:59 EDT
This incident affected: Nuance Management Center (Nuance Management Center - United States).