Updated version of the application has been released as of 8pm ET on 3/23/2026. Version 6.0.17 It is suggested that those utilizing their own identity providers for login take this update to remediate the issue previously encountered.
Posted Mar 24, 2026 - 08:06 EDT
Update
As remediation, Microsoft has created an updated version of the PMM/DAX Copilot mobile application and submitted it to Apple for approval. Once this has been approved and is available for download we will update this status. At this time, if you are manually updating your product, it is advised to NOT update to 6.0.16
Posted Mar 23, 2026 - 14:43 EDT
Update
The issue with PMM/DAX Copilot Mobile application has been identified and a remediation effort is underway. Another update is expected this afternoon at approximately 2:30pm ET. At this time, if you are manually updating your product, it is advised to NOT update to 6.0.16
Posted Mar 23, 2026 - 11:52 EDT
Identified
The PMM/DAX Copilot Mobile application is encountering an issue with presenting multiple identity providers. Engineering team is currently working to remediate the issue. During this time, if you are manually updating your product, it is advised to NOT update to 6.0.16
Posted Mar 23, 2026 - 10:45 EDT
This incident affected: DAX Copilot Mobile (DAX Copilot Mobile - Login).