Microsoft has identified and is working on remediation on the current NMC issue. Impact is that some admins working with the most recent Edge/Chrome browser updates, that also manage multiple organizations may be experiencing an issue with Orgnaization dropdown/selector.
Posted Apr 14, 2026 - 10:56 EDT
Update
Microsoft has identified and is working on remediation on the current NMC issue. Impact is that some admins working with the most recent Edge/Chrome browser updates, that also manage multiple organizations may be experiencing an issue with Orgnaization dropdown/selector.
Posted Apr 14, 2026 - 10:55 EDT
Identified
Microsoft has identified and is actively troubleshooting an issue affecting Nuance Management Console within our US datacenter following the latest Edge browser update. More details will be provided when information is available.
Posted Apr 14, 2026 - 10:18 EDT
This incident affected: Nuance Management Center (Nuance Management Center - United States).